حل مشکل بروزرسانی خودکار وردپرس

مشکل بروز رسانی خودکار وردپرس

حل مشکل  بروزرسانی خودکار وردپرس- در حال حاضر آخرین نسخه وردپرس (۵٫۱٫۱) در دسترس است.

شما به راحتی می توانید آن را از طریق admin ارتقا دهید.

بروز رسانی سایت شما بسیار ساده است: فقط باید وارد پنل شوید و با چند کلیک به طور خودکار هسته وردپرس، پوسته ها و افزونه ها را بروزرسانی کنید.

اما ممکن هست در یک لحظه، همه چیز تغییر کند و WordPress Auto-Update ناموفق باشد.

در این مقاله، هنگامی که بروز رسانی خودکار وردپرس شما کار نمی کند، به شما نشان می دهیم که چه باید بکنید.

چرا آپدیت خودکار وردپرس ناموفق می شود؟

دلایل متعددی وجود دارد که به موجب آن بروز رسانی خودکار وردپرس کار نمی کند مانند:

تغییر سطح دسترسی (مجوز) فایل ها، فعال بودن حالت امن (safe mode) ،اسکریپت زمان بندی سرور ، محدودیت حافظه PHP، و …

 

حل مشکل بروزرسانی خودکار وردپرس

قبل از اینکه ما به حل این مسئله برسیم، ابتدا ببینید که دقیقا در بروز رسانی خودکار چه اتفاقی می افتد.

 

Downloading update from http://wordpress.org/wordpress-5.1.1.zip…
Unpacking the update…
Verifying the unpacked files…
Installing the latest version…
Could not copy file.: /httpdocs/wordpress/wp-admin/js/list-table.dev.js
Installation Failed

پیام نمایش داده شده در بالا به شما می‌گوید که نصب وردپرس با مشکل مواجه شده و وردپرس هنوز به ورژن جدید بروزرسانی نشده است.

بعد از مشاهده این خطا چه کاری باید انجام دهیم!

 

۱٫بررسی سطح دسترسی فایل ها

 

یکی از مشکلاتی که ممکن است دلیل شکست بروزرسانی‌ خودکار در وردپرس باشد، سطح دسترسی (مجوز فایل) پوشه‌ها و فایل‌های وردپرس در هاست است.

برای اینکار به پنل مدیریتی هاست خود وارد شوید و در مسیر : wp-content/upgrade به دنبال فایلی بنام wordpress-4.tmp 

بگردید.

 

سطح دسترسی آن را بررسی کنید. سطح دسترسی این فایل باید بر روی ۷۷۷ باشد تا قابلیت بروزرسانی خودکار در وردپرس بدون مشکل فعال شود.

 

۲٫ سعی کنید حالت امن (safe mode) را خاموش کنید.

 

غیرفعال کردن حالت امن می تواند به شما در حل مسئله بروز رسانی خودکار کمک کند. کتاب راهنمای پی اچ پی می گوید که حالت امن از نسخه PHP 5.3.0 نادیده گرفته می شود.

برای انجام اینکار باید به مدیریت هاستینگ اطلاع دهید و اگر خودتان قادر به انجام این کار هستید:

کافی است کد زیر را در فایل فایل کانفیگ آپاچی httpd.config قرار دهید تا حالت امن سرور شما خاموش شود:

 

 

روش های فوق باید با موفقیت مشکل بروز رسانی وردپرس خودکار را حل کنند.

اگر شما هر روش دیگری را می دانید، لطفا در بخش نظرات با ما در میان بگذارید.

 

 

>> غیر فعال کردن بروزرسانی خودکار وردپرس و افزونه ها

درحال ارسال
امتیاز دهی کاربران
100 (1 رای)
ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

کد امنیتی Time limit is exhausted. Please reload CAPTCHA.